Terms
Edge Device - Performs L2 learning and forwarding on site facing interfaces an IP based virtualization on the transport facing interfaces. Can have multiple overlay interfaces per edge device.
Authoritative Edge Device - The AED is the designated forwarding device per each site. The election occurs across the internal interfaces of each edge device.
Join Interface -This is a point-to-point routed interface that is used by the edge device to join the overlay network. The IP of this interface is used to advertise reachability of MAC addresses at the site.
Overlay Interface - The overlay interface encapsulates L2 frames in IP unicast or multicast headers. It is multi-access and multicast capable.
MAC Routing - This process associates the destination MAC address of the L2 traffic to an edge device IP address.
Site - A L2 network that connects to both the transport and the overlay network.
Site VLAN - OTV sends hello messages on the site VLAN to detect other OTV edge devices in the site and it uses the Site VLAN to determine the AED for the Site. The Site VLAN should not extend across the overlay.
OTV Configuration
I used a real basic configuration consisting of four Nexus 7000's and two Ubuntu test machines. The even numbered 7K's run OTV and the odd 7K's simulate a transport network with multicast.
All of the 7K's run EIGRP for routing. The 7K-1 is the auto-RP for the multicast domain.
N7K-1 config:
interface Ethernet2/1
no switchport
ip address 1.1.1.1/24
ip router eigrp HELLA
ip pim sparse-mode
no shutdown
interface Ethernet2/2
no switchport
ip address 1.1.2.1/24
ip router eigrp HELLA
ip pim sparse-mode
no shutdown
router eigrp HELLA
address-family ipv4 unicast
autonomous-system 100
ip pim send-rp-announce Ethernet2/1 group-list 224.0.0.0/4
ip pim auto-rp mapping-agent Ethernet2/1
N7K-3 config:
interface Ethernet2/1
no switchport
ip address 1.1.1.3/24
ip router eigrp HELLA
ip pim sparse-mode
no shutdown
interface Ethernet2/2
no switchport
ip address 1.1.3.3/24
ip router eigrp HELLA
ip pim sparse-mode
no shutdown
router eigrp HELLA
address-family ipv4 unicast
autonomous-system 100
Now for the OTV configuration.
N7K-4 config:
vlan 510
name OTVSITE
vlan 999
name OTVEXTEND
otv site-vlan 510
interface Overlay1
otv join-interface Ethernet2/1
otv control-group 239.1.1.1
otv data-group 232.1.1.0/28
otv extend-vlan 999
no shutdown
interface Ethernet2/1
no switchport
ip address 1.1.2.4/24
ip router eigrp HELLA
ip pim sparse-mode
ip igmp version 3
no shutdown
interface Ethernet2/2
switchport
switchport access vlan 510
no shutdown
interface Ethernet2/3
switchport
switchport access vlan 999
no shutdown
router eigrp HELLA
address-family ipv4 unicast
autonomous-system 100
N7K-2 Config:
vlan 520
name OTVSITE
vlan 999
name OTVEXTEND
otv site-vlan 520
interface Overlay1
otv join-interface Ethernet2/1
otv control-group 239.1.1.1
otv data-group 232.1.1.0/28
otv extend-vlan 999
no shutdown
interface Ethernet2/1
no switchport
ip address 1.1.3.2/24
ip router eigrp HELLA
ip pim sparse-mode
ip igmp version 3
no shutdown
interface Ethernet2/2
switchport
switchport access vlan 520
no shutdown
interface Ethernet2/3
switchport
switchport access vlan 999
no shutdown
router eigrp HELLA
address-family ipv4 unicast
autonomous-system 100
Verification and Testing
The first step is to ensure that the overlay is up
N7K-4# sh otv
OTV Overlay Information
Overlay interface Overlay1
VPN name : Overlay1
VPN state : UP
Extended vlans : 999 (Total:1)
Control group : 239.1.1.1
Data group range(s) : 232.1.1.0/28
Join interface(s) : Eth2/1 (1.1.2.4)
Site vlan : 510 (up)
There should be an OTV adjacency with the other OTV edge device (N7K-2)
N7K-4# sh otv adjacency
Overlay Adjacency database
Overlay-Interface Overlay1 :
Hostname System-ID Dest Addr Up Time State
N7K-2 0050.56ba.3ca6 1.1.3.2 01:10:30 UP
We need to see if there is an L2 'route' for the MAC address of the Ubuntu-2 box that is connected to the N7K-2 Nexus OTV edge device.
The MAC address of the Ubuntu-2 ends in 5BD2
N7K-4# sh otv route
VLAN MAC-Address Metric Uptime Owner Next-hop(s)
---- -------------- ------ -------- --------- -----------
999 0050.56ba.5bba 11 00:08:20 site Ethernet2/3
999 0050.56ba.5bd2 42 00:00:01 overlay N7K-2
999 0050.56ba.5e60 42 01:50:52 overlay N7K-2