Fabric Path Notes

Below are notes I took when I did a Cisco PEC Fabricpath lab.

Overview and Notes

Fabricpath creates a network fabric using a group of switches.  The topology created consists of two trees. One is for unicast and broadcast.  Multicast uses both tress which is load balanced.

Externally, the network fabric created appears as a single switch to another switch. No STP runs inside the fabricpath domain.  Conversational MAC learning reduces the size of the MAC address table.

ISIS assigns addresses to all fabricpath switches automatically and shortest paths are computed. Up to 256 equal cost paths are supported.

The association between MAC address and Switch ID is maintained at the edge. Traffic is encapsulated using a MAC in MAC scheme.

M-Series I/O modules cannot switch fabricpath traffic.  FP core and CE edge must be on F series. Fabricpath VLANs can only be enabled on F series.

Default metric is 400 (for a 1G port)
10G is 40

Root for primary tree is based on the highest system-ID, then the highest Switch-ID if there is a tie.
The ingress switch determines which tree to use for each flow.  Hashed based tree for multicast. One FTag is assigned per tree.  One node is assigned primary for the broadcast tree.  This node also identifies another switch to become the root for the second tree.

vPC+

vPC+ switches operate at the edge of the fabricpath domain and connect to devices running STP via a vPC.  The peer vPC+ switches share a single FP switch-ID and form a 'emulated' switch. Must use F series I/O modules.  Conversion for vPC to vPC+ is disruptive. A VDC cannot run both vPC and vPC+; it must be one or the other.

Configuration

Basic Fabricpath

Install the fabricpath feature-set

conf t
feature-set fabricpath

Enable fabricpath for VLANs

vlan xxx
mode fabricpath

Enable interfaces for fabricpath
 switchport mode fabricpath

Setting the switch-id
 fabricpath switch-id xxx

Show the fabricpath routing table
show fabricpath route

Changing the root selection.  Default is 64.  Higher is preferred
fabricpath domain default
root-priority 255

Load balancing
fabricpath load-balance unicast ?

Fabricpath and Spanning Tree on a Nexus 5000 Edge (vPC+)

Fabricpath appears as a single bridge to all connected spanning tree devices.  The fabricpath Gateway must have the lowest spanning tree priority of all devices in the domain.

Create the usual vPC configuration with a peer-keepalive and peer-link.  Ensure that the same switch-id is used on each Switch.

Gateways should have spanning tree domain explicitly configured
spanning-tree domain XXX

Configure the VLANs with the lowest possible priority
spanning-tree vlan XXX priority 8192

The vPC peer link must be running fabricpath
switchport mode fabricpath

The last step is to connect the host to the vPC+ network

interface port-channel X
switchport mode access
switchport access vlan XXX
vpc X

int EX/X
switchport mode access
switchport access vlan XXX
channel-group X mode active
no shutdown

The VLAN used by the vPC+ member port must be associated with Fabricpath otherwise it will be suspended from the vPC+ member port.

vPC+ on Nexus 7000 for an L2/L3 Boundary

This  lab has a pair of N7K's that provide L3 connectivity to the L2 fabricpath domain. A vPC+ is configured with active/active HSRP. M series cards are used for L3 and F series for the fabricpath portion.



vrf context VRF1
vrf context VRF2
vrf context management
  ip route 0.0.0.0/0 10.0.8.254
vlan 1
vlan 100
  mode fabricpath
vpc domain 2
  peer-keepalive destination 10.0.8.183
  peer-gateway
  fabricpath switch-id 2

interface Vlan1

interface Vlan100
  no shutdown
  vrf member VRF1
  no ip redirects
  ip address 100.100.100.1/24
  ip ospf passive-interface
  ip router ospf 1 area 0.0.0.0
  hsrp version 2
  hsrp 100
    ip 100.100.100.254

interface port-channel1
  switchport
  switchport mode fabricpath
  vpc peer-link

interface Ethernet1/21
  switchport mode fabricpath
  switchport trunk allowed vlan 100
  no shutdown

interface Ethernet1/22
  switchport mode fabricpath
  switchport trunk allowed vlan 100
  no shutdown

interface Ethernet1/23
  switchport mode fabricpath
  switchport trunk allowed vlan 100
  no shutdown

interface Ethernet1/24
  switchport mode fabricpath
  switchport trunk allowed vlan 100
  no shutdown

interface Ethernet1/25
  switchport mode fabricpath
  switchport trunk allowed vlan 100
  no shutdown

interface Ethernet1/26
  switchport mode fabricpath
  switchport trunk allowed vlan 100
  no shutdown

interface Ethernet1/27
  switchport mode fabricpath
  switchport trunk allowed vlan 100
  no shutdown

interface Ethernet1/28
  switchport mode fabricpath
  switchport trunk allowed vlan 100
  no shutdown

interface Ethernet1/29
  switchport mode fabricpath
  channel-group 1 mode active
  no shutdown

interface Ethernet1/30
  switchport mode fabricpath
  channel-group 1 mode active
  no shutdown

interface Ethernet3/21
  vrf member VRF1
  ip address 37.1.1.1/24
  ip router ospf 1 area 0.0.0.0
  no shutdown

interface mgmt0
  ip address 10.0.8.173/24
line vty
router ospf 1
  vrf VRF1
  vrf VRF2
fabricpath domain default
  root-priority 255
fabricpath switch-id 71