The Nexus 7000 supports both V2 and V3. The primary difference with V3 is support for IPV6. Both V2 and V3 can be configured and used simultaneously on the same VDC.
As a refresher, these parameters must match for a neighbor relationship to form:
- Hello interval
- Dead interval
- Area ID
- Authentication
- Optional capabilities
- IP MTU's must also match. The interface level command 'ip ospf mtu-ignore' allows differing MTU values
- Stub - all routers in the area are stub. No ASBRs and no virtual links.
- NSSA - Allows the use of an ASBR. Area 0 cannot be NSSA
- Totally Stubby - default route only using no summary option
- Don't forget that a virtual link must be used to connect non area 0 areas together if they are logically connected.
Administrative distance 110
Hello interval 10 seconds
Dead interval 40 seconds
Graceful restart grace period 60 seconds
OSPFv2 feature Disabled
Stub router advertisement announce time 600 seconds
Reference bandwidth for link cost calculation 40 Gb/s
LSA minimal arrival time 1000 milliseconds
LSA group pacing 10 seconds
SPF calculation initial delay time 200 milliseconds
SPF minimum hold time 5000 milliseconds
SPF calculation initial delay time 1000 milliseconds
Authentication
You can configure authentication for all networks in an area or for individual interfaces in the area.
Interface authentication configuration overrides area authentication.
Route Filtering Between Areas
This is a simple ACSII depiction of the topology I used to test
N7K-4 <--- area 1 ---> N7K-1 <--- area 0 ---> N7K-3 <--- area 2 ---> N7K-2
You can filter on ABRs between areas. The configuration below uses two loopbacks on the N7K-2 router with addresses 2.1.1.1/24 and 2.1.2.1/24. I'm going to filter the 2.1.2.1/24 network as routes pass from area 2 to area 0 on N7K-3
ip prefix-list DENY212 seq 5 deny 2.1.2.0/24
ip prefix-list DENY212 seq 10 permit 0.0.0.0/0 le 32
route-map RM-DENY212 permit 10
match ip address prefix-list DENY212
router ospf HELLA
area 0.0.0.2 filter-list route-map RM-DENY212 out
Here is the routing table for OSPF on N7K-1 showing that the route is missing:
N7K-1# sh ip ro ospf-HELLA
1.1.3.0/24, ubest/mbest: 1/0
*via 1.1.1.3, Eth2/1, [110/80], 01:09:36, ospf-HELLA, inter
2.1.1.0/24, ubest/mbest: 1/0
*via 1.1.1.3, Eth2/1, [110/81], 00:12:01, ospf-HELLA, inter
4.1.1.0/24, ubest/mbest: 1/0
*via 1.1.2.4, Eth2/2, [110/41], 00:11:05, ospf-HELLA, intra
4.1.2.0/24, ubest/mbest: 1/0
*via 1.1.2.4, Eth2/2, [110/41], 00:10:29, ospf-HELLA, intra
Another verification step
N7K-3# sh ip ospf policy statistics area 0.0.0.2 filter-list out
C: No. of comparisons, M: No. of matches
route-map RM-DENY212 permit 10
match ip address prefix-list DENY212 C: 4 M: 4
Total accept count for policy: 3
Total reject count for policy: 1
Originate a Default Route
Nothing special but can use a route-map for conditional advertisement
router ospf HELLA
default-information originate always
Limiting the Number of Redistributed Routes
Same format as EIGRP
N7K-3(config-router)# redistribute maximum-prefix 10 ?
<CR>
<1-100> Threshold value (%) at which to generate a warning message
*Default value is 75
warning-only Log a warning message when limit is exceeded
withdraw Withdraw all redistributed routes
Summarization
Same rules as in any Cisco OSPF
ABR - Area range command in routing process
ASBR - Summary address is routing process
Changing Administrative Distance of Routes
I can't test this so I'm including an example from the routing guide:
switch# configure terminal
switch(config)# router ospf 201
switch(config-router)# table-map foo
switch(config-router)# exit
switch(config)# route-map foo permit 10
switch(config-route-map)# match route-type inter-area
switch(config-route-map)# set distance 150
switch(config)# route-map foo permit 20
switch(config-route-map)# match route-type external
switch(config-route-map)# set distance 200
switch(config)# route-map foo permit 30
switch(config-route-map)# match ip route-source prefix-list p1
switch(config-route-map)# match ip address prefix-list p1
switch(config-route-map)# set distance 190